Melhorando o desempenho do GPS do Galaxy W

Quando o aparelho ainda está com as configurações de fábrica demora um pouco mais para fixar os satélite, em dias nublados o GPS do Galaxy W demora mais ainda, as vezes demora muito mais,  isso porque o Galaxy vem com a configuração dos servidores NTP da América do Sul, o Brasil possui um conjunto próprio de servidores NTP e alterando a configuração o tempo para travar os satélites diminui muito..

Com o procedimento a seguir o meu Galaxy W em tempo ensolarado fixa os satélites em menos de 15 segundos e com tempo nublado entre 30 segundos e 4 minutos (Melhor e pior desempenho).

Para iniciar é necessário que o seu aparelho já esteja com o Root habilitado, vou usar o ES  File Explorer no meu exemplo, com outros gerenciadores também deve funcionar, usei este que já vem com um bloco de notas embutido o que facilita a operação.

Abra o ES File Explorer e siga os exemplos:

Clique em favoritos e selecione a pasta raiz, ache a pasta etc

Clique em favoritos e selecione a pasta raiz, ache a pasta etc

Dentro da pasta etc esta o arquivo gps.conf que vamos modificar

Dentro da pasta etc esta o arquivo gps.conf que vamos modificar

Utilize a opção Copiar (Ou cortar)

Utilize a opção Copiar (Ou cortar)

Selecione favoritos de novo, Selecione o SD Externo e use a opção colar, o arquivo gps.conf vai aparecer no SD

Selecione favoritos de novo, Selecione o SD Externo e use a opção colar, o arquivo gps.conf vai aparecer no SD

No arquivo que está no SD use a opção abrir e selecione ES Editor de notas

No arquivo que está no SD use a opção abrir e selecione ES Editor de notas

Esse é o arquivo com o servidor da América do Sul (south-america.pool.ntp.org)

Esse é o arquivo com o servidor da América do Sul (south-america.pool.ntp.org)

Delete "south-america" e coloque "br" no lugar, a linha vai ficar assim: NTP_SERVER=br.pool.ntp.org

Delete "south-america" e coloque "br" no lugar, a linha vai ficar assim: NTP_SERVER=br.pool.ntp.org

Utilize a opção salvar

Utilize a opção salvar

Copie arquivo que foi salvo no SD

Copie arquivo que foi salvo no SD

Navegue até a pasta etc na raiz usando os favoritos e mande colar, ira aparecer a mensagem acima, clique em OK e o seu novo arquivo estará salvo no dispositivo

Navegue até a pasta etc na raiz usando os favoritos e mande colar, ira aparecer a mensagem acima, clique em OK e o seu novo arquivo estará salvo no dispositivo

Clique em algum aplicativo que usa o GPS e veja se o tempo para fixar melhorou no Endomondo demorou apenas 9 segundos para ficar OK

Clique em algum aplicativo que usa o GPS e veja se o tempo para fixar melhorou no Endomondo demorou apenas 9 segundos para ficar OK

You may also like...

60 Responses

  1. Eu tenho usado muito o GPS, por volta de 4 horas direto três vezes por semana a um ano e nunca tive problemas com o Galaxy W, na verdade desisti de compra um Garmin Edge 800 e acabei economizando uma baita grana HEHE

  2. GugaHerz disse:

    Ola Fernando, cara passei o maior aperto confiando no gps do Galaxy W, o filho da mãe me deixo na mão mais de uma vez quando precisei do gps, pois utilizo uma versão paga so Sygic que é fantástico.
    Impossível um software tão bom quanto este não funcionar, ai comecei a notar a demora em conseguir o sinal do gps na maioria das vezes sem sucesso, ai fiquei puto e comecei a pesquisar , já utilizei seu blog mais de uma vez para buscar informações e sempre deu certo.
    Desta vez encontrei o post para melhorar o sinal do gps e não pensei duas vezes.
    Refiz a instalação do Firmware, depois atualizei pelo Kies a nova versão , copiei os arquivos para fazer o root e bingo ! , funfou , consegui alterar o arquivo gps.conf, agora estou iniciando uma bateria de testes com o gps mas a principio o negocio ta indo bem.
    Semana que vem farei uma viagem bem longa e vou utilizar o mesmo, depois comento novamente para contar a experiencia e se o negocio vingou mesmo.
    Cara obrigado mais uma vez pelas informações seu blog é o melhor em informação, conteudo e clareza nos exemplos. valeu ! Abraços

  3. Verifique se o icone do GPS está verde na aba de notificações, se ele não achar nenhum satélite depois de uns vinte minutos em uma área aberta, ele pode estar com algum defeito.

  4. Daniel disse:

    Caramba rapaz, eu fiz isso e não adiantou nada. O meu GPS nem demora, ele simplesmente não acha nada. O que pode fazer? Vocepode me mandar o seu arquivo.conf já pronto?
    att

  5. Deixa as configurações originais e testa pra ver se fixa, pode ser um problema no módulo de GPS, aqui demora no máximo 10 minutos com as configurações originais para pegar localização

  6. rianmendes disse:

    Nem assim mano, deixei uns 15 minutos e nada…

  7. rianmendes disse:

    nunca deixei 10 minutos pra saber, vo fazer o teste

  8. Ele não conecta nem depois de 10 minutos?

  9. rianmendes disse:

    fiz tudo que vc mando, mas meu gps não sai de “ESPERANDO LOCAL”, o que pode ser

  10. Carlos Cardoso disse:

    Fiz tudo igual e deu tudo certo, sem nenhum problema falta só testar agora.

  11. Oi Farley aqui em São Paulo ele fixa em segundos com as do meu post, com tempo nublado também demora mais por aqui

  12. Farley disse:

    Eu uso tem quase 2 anos com o Sygic: GPS Navigation, Estou em Belo Horizonte MG e estas configurações são bem melhores que as originais pois leva cerca de 10 segundos para sincronizar. Eu uso o GPS quase todos os dias para trabalho aqui na região porem, para viagens inter estaduais ou municipais eu uso o automotivo Apontador T430 que é mais preciso e traça rotas melhores mesmo quando tempo esta nublado pois tempo nublado o celular demora muito a sincronizar e fica perdendo sinal a todo instante. Meu aparelho é o Galaxy W Android 2.3.6

  13. Oi Farley, obrigado pela dica, você sentiu alguma mudança no posicionamento? A quanto tempo você está usando essa config e você usa muito o GPS? Eu te pergunto porque já usei algumas dessas configs aqui em São Paulo e o resultado foi ruim. Essas configurações são para uso na Argentina que tem poucos servidores NTP e usa muito os do Brasil.
    As frases INTERMEDIATE_POS=1 e ACCURACY_THRES=5000 costumam ter resultados muito diferentes dependendo da região em que você está.
    O pool atual do brasil é esse br.pool.ntp.org e contém os seguintes servidores:
    server 0.br.pool.ntp.org
    server 1.br.pool.ntp.org
    server 2.br.pool.ntp.org
    server 3.br.pool.ntp.org
    cl, ar, ve e south-america estão distantes então podem piorar a fixação para quem está longe das fronteiras.

  14. Farley disse:

    Edita o arquivo gps.conf com esses aqui que resolve o problema de quem nao conseguiu.

    apaga tudo que está lá e coloca isso que está abaixo

    faça um bkp do gps.conf antes

    NTP_SERVER=c.ntp.br
    NTP_SERVER=1.br.pool.ntp.org
    NTP_SERVER=cl.pool.ntp.org
    NTP_SERVER=ar.pool.ntp.org
    NTP_SERVER=ve.pool.ntp.org
    NTP_SERVER=0.south-america.pool.ntp.org
    NTP_SERVER=1.south-america.pool.ntp.org
    NTP_SERVER=2.south-america.pool.ntp.org
    NTP_SERVER=3.south-america.pool.ntp.org
    XTRA_SERVER_1=http://xtra1.gpsonextra.net/xtra.bin
    XTRA_SERVER_2=http://xtra2.gpsonextra.net/xtra.bin
    XTRA_SERVER_3=http://xtra3.gpsonextra.net/xtra.bin
    INTERMEDIATE_POS=1
    C2K_HOST=c2k.pde.com
    C2K_PORT=1234
    SUPL_HOST=FQDN
    SUPL_HOST=supl.google.com
    SUPL_PORT=7276
    SUPL_SECURE_PORT=7275
    SUPL_NO_SECURE_PORT=3425
    SUPL_TLS_HOST=FQDN
    SUPL_TLS_CERT=/etc/SuplRootCert
    ACCURACY_THRES=5000
    CURRENT_CARRIER=common
    DEFAULT_USER_PLANE=TRUE
    REPORT_POSITION_USE_SUPL_REFLOC=1

  15. Gullas disse:

    Pois é, no inicio funcionou tranquilo, mas agora demora muito para pegar.

  16. Oi Gullas, como você já alterou os servidores NTP não há mais nenhuma configuração pra modificar, nesse período do ano pelo menos aqui em SP o clima atrapalha bastante a recepção do GPS.

  17. Gullas disse:

    Sim. Está sempre habilitado.

  18. Oi Gullas, você mantêm o AGPS habilitado? Sem ele demora um pouco para fixar.

  19. Gullas disse:

    Olá Akira, segui seu tutorial, fiz tudo certo, verifiquei se não continha erros, mas gps continua demorando para conectar. No início, logo quando fiz a configuração, funcionava bem. Rapidamente conectava, mas depois parou e começou a demorar. O que posso fazer? Agradeço desde já pela ajuda.

  20. Que bom por enquanto todo mundo que alterou o NTP tá feliz com o resultado, numa manha ensolarada o meu fixou em menos de 10 segundos eu fiquei pasmo!

  21. Fabio Bulgareli disse:

    Legal Akira. Instalei aqui e vou testar… parece ser muito bom mesmo… Valeu pela dica!

    Ah! Fiz o teste do GPS e realmente ficou muito mais rápido. Conectou hoje em menos de 2 minutos, e o tempo hoje está muito nublado.

  22. HEHE valeu, essa é a intenção do blog, eu procurei muito pra achar essas informações a galera ta preocupada só com o SGS SGSII

  23. Marcilio Lacerda disse:

    Fernando tu é PHODAAAA o meu sinal do GPS agora ta muitooo rapido mesmo antes era uma eternidade agora ligou achou com o IGO….vlw Fernando sempre salvando a galera….site 100000000000000000000

  24. Oi Fábio nesse teclado que uso o Swiftkey a proposta é diferente, não dá para usar como o Swipe, mas ele tem uma vantagem, ele aprende o seu vocabulário através do que você teclar ou habilitando o aprendizado no seu Facebook, Twitter, Gmail ou RSS.
    Assim o que você costuma usar aparece como dica na tela e fica fácil basta clicar em cima e ele digita, se você quiser excluir alguma palavra desse dicionário basta apertar a palavra e segurar e a opção de deletar aparece.
    Todo o resto é customizável, as cores, a altura das telas, velocidade de digitação, linguás instaladas (03 consecutivas) e muito mais. Eu peguei a versão de teste e depois de uma semana comprei a completa. No meu caso valeu a pena. Achei um review dele aqui

  25. Fabio Bulgareli disse:

    Akira, feito. Só falta testar agora, vou fazer isso.

    Me responda uma coisa, gostei desse teclado que vc está usando… o swipe dele é bom? Qual o nome desse teclado?

    Abraço

  26. Oi Thiago, eu nunca usei o Backitude, na verdade depois que alterei o servidor NTP o GPS tem fixado mais rápido então tenho dispensado outros programas que auxiliam no GPS to usando só o Maps e o Endomondo

  27. thiago disse:

    Akira, sim cara tive que desinstalar e instalar de novo ai reiniciei ele funcionou blz, teve algumas atualizações que tava dando erros em alguns aplicativos tive que fazer o mesmo mas agora ta tudo rondando perfeitamente aqui na minha cidade lavras minas gerais tbm esta chovendo mas consegui fazer o gps funcionar na hora do almoço depois nao testei de novo mas acredito que esteja tudo normal.
    um app que baixei e que tbm ajudou bastante na procura de rede foi o backitude agilizou bastante . si vc usar ai me diga o que achou e que experiencia vc teve com ele ai.

    valeu grande abraço

  28. Oi Thiago, você precisou reinstalar? Aqui em São Paulo hoje está difícil de fixar, o tempo não está ajudando.

  29. thiago disse:

    blz cara o mapa agora funcionou , so o gps que fica pesquisando e nao acha

  30. Oi Thiago, essa mensagem informa que o apk do maps está com algum problema não tem relação com o servidor NTP que você alterou, você excluiu algum apk do sistema da Google? Latitude, gtalk, gmail etc? Ou akgum outro arquivo do sistema. Eles costumam ser dependentes se algum foi desinstalado pode estar causando esse erro. Se você reiniciar o Galaxy W e o problema se repetir experimente entrar no Google Play e atualizar o Maps, se não der certo entre no gerenciador de aplicativos e desinstale a atualização do maps e teste o apk depois atualize ele novamente.

  31. thiago disse:

    Akira , muito obrigado pelas informações vc realmente esta ajudando muita gente ai que tem o w e não achava nada para o nosso aparelho. cara estou com um problema talvez vc possa me ajudar depois que fia a alteração no gps o mapa da google fecha com a seguinte mensagem(processo com.google.android.apps.maps)parou inesperadamente. tente novamente.

    e nao abre so da essa mensagem e fecha vc ja viu algo assim ou algo que eu fiz errado ? no meu caso do gps tbm estava com a configuraçao do mapa para nort america ai troquei para br tem algo a ver ?
    desde de ja agradeço valeu.

  32. andrepteixeira disse:

    Show!!!

  33. Aqui em SP quando o tempo está muito encoberto o GPS demora mas é geral mesmo o Hollux e o Garmin demoram mais pra fixar e perdem o sinal com facilidade

  34. ErivandoXP disse:

    Estou em Juazeiro do Norte – CE, resolvi deixar “Utilizar redes sem fios” marcado agora, pois a consulta fica bem rápida.

  35. Uma causa para demora pode estar relacionada com as condições climáticas você tá aqui em SP?

  36. ErivandoXP disse:

    Eu tive o cuidado de fazer backup antes. E comparei os arquivos, está tudo certo. Mas caso eu não marque “Utilizar redes sem fios” demora uma eternidade pra mostrar o meu local.

  37. O item “Utilizar redes sem fios” é independente do GPS, se você desmarca e não funciona o GPS parece estar desligado. Cheque novamente o arquivo gps.conf deve ter algo errado nele

  38. Oi Erivando, não precisa fazer mais nada além de trocar o server para br.pool.ntp.org. Verifique o arquivo gps.conf compare com o do post para ver se na hora de editar alguma outra linha ficou colada ou se faltou algum simbolo.

  39. ErivandoXP disse:

    Tava verificando aqui em “Configurações/Localização e Segurança” o item “Utilizar redes sem fios” é preciso ficar marcado?

    Quando marco funciona a localização, se desmarcar não funciona…

    PS.: Os outros já estão marcados: “Utilizar satélite GPS” e “Utilizar ajuda de sensores”.

  40. ErivandoXP disse:

    Cara fiz todo o procedimento, meu servidor estava (north-america.pool.ntp.org).

    Mudei pra (br.pool.ntp.org) e agora não consegue mais localizar. Nem no App Estado do GPS não trava mais…

    No navegador de GPS fica sempre esperando local e não sai disso, já desfiz as alterações, salvei e deliguei o celular e mesmo assim não tá dando certo…

    Precisava fazer alguma coisa a mais?

  41. Talvez tenha alguma diferença no sistema de root nesse que eu uso o superuser dá as permissões direto, você tentou usar outro explorador de arquivos?

  42. Munhoz disse:

    eu rootiei meu cel pelo aquele programa lá do baixaki que faz root sozinho.

  43. Você tá usando alguma das ROMS que eu postei aqui no blog e habilitando o Root seguindo o meu passo a passo? No meu ele simplesmente ativa. Se você estava com alguma ROM do Cyanogen e atualizaou com uma ROM que eu indiquei faltou resetar para os padrões de fábrica. Não deveria aparecer essa mensagem, ele simplesmente habilita o Root Explorer e pronto é só usar.

  44. Munhoz disse:

    quando eu habilito a opçao lá do root explorer aparece um negocio assim ” select ROM ae tem Cyanogen Mod e HiAPK” ae eu clico em algum dos 2 mais mesmo assim não consigo habilitar depois esse Montar o sistema de arquivos

  45. No ES File Explorer clica no botão de menu, entre em configurações role a tela até aparecerem as opções de Root, habilite a opção root explorer e a opção Montar o Sistema de Arquivos

  46. Munhoz disse:

    O meu também ta dando erro na hora de passar o arquivo salvo pro etc..
    onde ta esse negocio de “Montar o sistema de arquivos para gravação”?

  47. Tem um passo a passo aqui no blog de uma olhada aqui

  48. pakana disse:

    é dificil habilitar o root? c não for pedir muito, desde já agradeço sua atenção.

  49. O root só é necessário caso você precise instalar algum programa que necessita desse acesso, ou você precise alterar algum arquivo de configuração. Se você não pretende mexer mais a fundo no sistema não é necessário. É bom usar o Root com cuidado porque ele modifica o rom de forma permanente se você alterar alguma coisa sem ter feito um backup e ocorrer algum erro você terá que reinstalar o firmware 2.3.6

  50. pakana disse:

    ok, vc acha q eu deva fazer este processo : http://android.nogiro.com.br/2012/03/07/como-habilitar-o-root-no-samsung-galaxy-w-gt-i8150-com-o-android-2-3-6/

    lembrando, meu w i8150 já está com o 2.3.6

  51. Você está com o root habilitado? Caso contràrio não será possível montar para leitura e gravação

  52. pakana disse:

    seria em configurações/opções de root/montar o sistema de arquivos…..se sim esta opção está oculto, ou seja, não habilita está cinza…estou usando a versão android 2.3.6, obrigado pela atenção.

  53. Pakana, você tá usando o Es File Explorer? Se está checou se o sistema de arquivos está montado para leitura e gravação?

  54. pakana disse:

    Akira, tive o mesmo problema, ou seja, consegui editar e salvar no sd mas na hora de salvar transferir e salvar no etc ele não salva, ele da a mensagem certinho como na sua foto “CUIDADO! vc deseja sobrescrever” confirmo “sim” mas da erro, pena q Renato não compartilhou, né.

  55. Ok, esse aplicativo grava o server sem ter que editar o gps.conf? Se for me passa o link pode interessar ao pessoal que acessa o blog.

  56. Renato disse:

    Agora está! Mas eu baixei outro aplicativo que me permitiu gravar o server para o Brasil. Obrigado!

  57. Nas configurações do ES Explorer está habilitada a opção de “Montar o sistema de arquivos para gravação”?

  58. Renato disse:

    Acredito que sejam as permissões, mas como faço para mudar?

  59. Renato disse:

    Problemas! Não consigo salvar o arquivo alterado. Tanto a cópia dá erro, quanto a simples alteração do arquivo. O que pode ser?

Deixe uma resposta